pepsimax007
Posts: 5
Joined: Mon May 21, 2018 9:40 am
PC Specification: i7-7700K @ 4.20GHz / GeForce GTX 1080 Ti

Corrupted uploads

Mon May 21, 2018 10:24 am

As the title describes; files are being corrupted when uploaded. Further details below.

Whenever I upload a video either using the upload function of Action! or a file which was recorded using Action! it will always end up with some sort of partially corrupted footage. It also always seems to be the beginning of the video which is damaged, opening the file is fine but it is only when it is uploaded this happens.

Examples:
https://www.youtube.com/watch?v=TVzbSAEZHq0
https://www.youtube.com/watch?v=64H9t2Jey5k
https://www.youtube.com/watch?v=TCWu3YaVBUE
https://www.youtube.com/watch?v=xo95gWTQegE

The first seconds are completely indistinguishable, you don't even know what you are looking at, but corrects itself later.
The file itself is perfect and it is nothing like this when I open it with Splash or any other video playback software. It only happens when I upload it.

I tried uploading other items and they are completely fine. I also uploaded through another computer and it worked as well (it has an older version of Action! if that's any relevant)

What patterns I've noticed:
  • It always seems to start with a solid gray and (as the pixels are changing color?) slowly corrects itself.
  • The longer the video the longer the duration of this phenomenon, ie. it's proportional.
Settings used to record don't seem to affect this either, I've poked around and tried my best to find a solution on my own but with no result.
I should also mention that this began a few months back after I downloaded an update for the program.

I have used Mirillis™ Action! since 2012 and it worked wonders. I have another computer with a version from around 2014 and that one is fine.

I don't think my pc would be the issue here since it's not even 1 year old and I have not had a single problem with it so far or any programs(except this).

My PC specs:
CPU: Intel Core i7-7700K @ 4.20GHz
GPU: Nvidia Geforce ASUS GeForce GTX 1080 Ti ROG Strix
SSD: Samsung 850 Pro 512GB
SSD: Samsung SSD 850 EVO SSD 1TB
HDD: Seagate Internal Harddrive Firecuda 2TB SSHD
Memory: Corsair Dominator Platinum 32GB 3466Mhz
MOBO: ASUS ROG Maximus IX Extreme Z270 eATX
OS: Windows 10 Home 64-bit DVD English OEM


TL;DR
See examples

Thank you for your help

pepsimax007
Posts: 5
Joined: Mon May 21, 2018 9:40 am
PC Specification: i7-7700K @ 4.20GHz / GeForce GTX 1080 Ti

Re: Corrupted uploads

Sun May 27, 2018 8:01 pm

*** SOLVED ***

SOLUTION:
So after a very long and thorough investigation into this issue I found that the root of this problem was the hardware acceleration, which along with some files in the program made this problem occur. I was able to simply change the hardware acceleration setting or disable it completely to avoid this but I was determined to want full access to the program without limitations. As well as future-proofing so I wouldn't have to go through this again or similar. Editing the files, crossing my fingers and et voilà ! I managed to pull it off. This was done on the 3.1.3 version of the program, and after updating to the 3.1.4 still holds strong thankfully!
Video examples I made prior to the files being edited, demonstrating the issue(recording settings in video description):
https://youtu.be/xi35TD1bv-k - Problem (NVIDIA NVENC HEVC / GAME)
https://youtu.be/YIJuyNY_CHc - OK (NVIDIA NVENC / GAME)
https://youtu.be/IrE7P2_E_QM - OK (Hardware acc. DISABLED / GAME )
https://youtu.be/gZpI4uiHg50 - OK (Hardware acc. DISABLED / SCREEN)

https://youtu.be/aOgRy2guKQQ Demonstration of what the actual file was like, on my computer after recording with NVIDIA NVENC HEVC enabled.
https://youtu.be/l8IQAL5FS5M Same file, after upload.

I hope this will help someone who might be experiencing the same issue and hopefully won't have to go through this ordeal in order to share their content, or at the very least make it easier. Also if the developers of Action! can look through this and triple-check so it's not the codes/files but rather just a one-off on my program. And if it turns out to be faulty fix it for 3.1.5 =D

TL;DR
Hardware acceleration setting "NVIDIA NVENC HEVC" was the cause of this problem, change or disable to quick-fix.

*** SOLVED ***

keshacarey
Posts: 1
Joined: Thu Aug 30, 2018 3:09 pm
PC Specification: Windows 10

Re: Corrupted uploads

Tue Sep 04, 2018 1:19 pm

Thanks for the solution, i was also facing the same problem. Very helpful solution.

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 3 guests